Loomio

Updating database from 9.6 to 12.2

CF
Colin Fletcher Public Seen by 17

Hi everyone,

I'm updating my Loomio installation by incrementally updating my loomio-deploy repository and running the rake:migrate procedure.

I've run into a problem at this revision, which updates the postgres container from version 9.6 to 12.2. When I try to run the migration the db complains that it can't load from incompatible database files.

I saw this suggestion to set the db container tag back to 9.6 before continuing to update. Can it be left like that in the migration all the way up to the current version?

I'm assuming that it'll eventually need to be converted anyway. Is there a way to do that using the postgres container rather than the tools installed on the host system? My host doesn't feature a version of postgres that is recent enough to do the job.