Loomio

Installing Loomio

DU
[deactivated account] Public Seen by 531

I propose that the instructions on the Github wiki page for installing Loomio on a local machine specify the versions of Ruby and Rails on which Loomio is expected to run.

In the short term, hand-coding the recommended/supported version(s) of Ruby, Rails and even known good OS platforms into the install instructions would be helpful.

In the longer term, I (naively) wonder if there's a way for the Wiki page to pull the value(s) from the app Gemfile, or to have the value specified somewhere common to the Rails app and the wiki (i.e. keep it DRY)?

This is also important now as Ruby and Rails are both transitioning major versions. Perhaps a continuous build (Jenkins? Hudson!?) against various versions of Ruby and Rails would help keep developers informed of the status of the code, at least on major platform revisions?

AT

Aaron Thornton Fri 5 Apr 2013

At the moment between our local developers we have it running on Linux, OSX Snow Leopard and OSX Lion. I am running Ruby version is 1.9.3 and Rails version bundled is 3.2.13. @johnirving what do you think about Phillips idea. I know we used to have this information in an install doc. Have you had any previous corrrespondance with @jonlemmon on this?

MI

mix irving Sat 6 Apr 2013

I'm running Ubuntu 12.10 (with gnome 3)
Ruby 1.9.3p327
Rails 3.2.13

agree on the idea of being explicit about versions used.
If you follow the Mike Hartl tutorial for installing rails (link at the start of the Install on a local machine wiki page) it should work a treat

DU

[deactivated account] Mon 8 Apr 2013

Thanks for the feedback! I've been experimenting with vagrant + puppet + VirtualBox + Ubuntu 12.10 to create a stable, reproducible Rails development environment. I run the Rails app by ssh'ing into the virtualbox guest, and do my Vim editing and git-stuff from Cygwin terminal sessions on the Windows host side. Complicated, but it lets me stay on Windows and eat my Rails cake too :)

This is my setup:
Host OS: Windows 7 Pro SP1 with Vagrant 1.1.5 for guest OS management
Guest OS: Ubuntu 12.10 64bit (on VirtualBox 4.2.10 r84104), using puppet 2.7.19 on system Ruby 1.8.7

The Rails environment within the loomio app as managed on the Ubuntu guest by RVM 1.19.1:
Ruby: 1.9.3p392
Rails: 3.2.13
PostgreSQL: 9.1

I ran into lots of nit-picky problems getting the PostgreSQL permissions working in the database.yml config file and the PostgreSQL config file pg_hba.conf, in fact I'm still not sure it's configured correctly, so more details on the wiki page would be helpful.

Particularly for PostgresQL:
- created a password "password" for the default postgres database user, otherwise I got "peer authentication" failures when running rake db:create
- had to add these attributes to the development and test sections of database.yml so the app could authenticate and use the UTF-8 db template:

password: "password"
template: template0

  • altered the default admin login record in pg_hba.conf from local all postgres peer to local all postgres md5

to enable password authentication.

As I said, I'm new to postgres and not at all sure if this is the preferred way to configure things, but I can now at least start up the loomio app!

MI

mix irving Mon 8 Apr 2013

I had a lot of problems with postgres the first time I installed and read and tinkered a lot with that pg_hba.conf file

if i recall, the last time I installed I managed to hit the nail on the head setting up a postgres user for the computer and database at the same time, but didn't note the specific commands :(

what does puppet do?
I'm sure if you get a vagrant image (termonoligy?) up and running the community would be most interested in access to that.

MI

mix irving Mon 8 Apr 2013

also, if you share your vagrant setup we could have a look over it to see how it's configured.

for my own learning curve I steered clear of a vagrant solution which was knocking around here because I wanted to eliminate as many variable as possible

MB

Matthew Bartlett Wed 10 Apr 2013

FWIW, I found Loomio on vagrant HEAPS slower than Loomio just running on OS X.

DU

[deactivated account] Wed 10 Apr 2013

@johnirving yes I've also been shedding tears over postgresql configuration. I found lots of stack overflow discussions describing the password errors that didn't quite explain how to fix them. For me I think it's a matter of learning more about postgresql. I'll try to document it in some way.

@matthewbartlett, concur, by running on the bare OS you avoid all the overhead of the VM itself, but Rails on Windows is a non-starter, that's how I ended up with the configuration I described below. Perhaps I should just succumb and buy a Mac :)

Vagrant and puppet did take some time to understand and configure for my purposes, but I feel it's given me a lot more freedom to experiment with different configurations, and not worry about losing days of setup if I mess up the VM or delete something.

@johnirving, puppet (see https://puppetlabs.com/puppet/what-is-puppet) is a tool for automating the management of the VM configuration. After vagrant creates the base VM, it invokes puppet (from Ubuntu on the VM) to install and update RVM, Ruby, PostgreSQL, etc. in a reproducible way - if I screw things up beyond redemption on my VM, I can just call "vagrant destroy" to nuke it then "vagrant up" to recreate it.

Vagrant can share directories between the Ubuntu and Windows file systems, so I can do my coding from the Windows side (actually using Vim through Cygwin, but that's another story) and running the Rails app from an ssh shell into the Ubuntu VM.

My vagrant configuration is at https://github.com/psteiner/rails-starter-box if you want to have a look. I am still learning lots about puppet and vagrant, so it may not be optimal :)

As a side note, a new posting on the Discourse project blog discusses recommendations for running their Rails app in a VM http://blog.discourse.org/2013/04/discourse-as-your-first-rails-app/, basically throw lots of RAM and SSD at it. I guess this is endemic to developing Rails in a VM.

DU

[deactivated account] Wed 10 Apr 2013

Also wondered how and where is Loomio itself hosted and configured?

JL

Jon Lemmon Thu 11 Apr 2013

Great info Philip. It would be great if we can offer a good consistent Loomio Vagrant setup for developers like yourself.

We're currently running on Heroku but plan to switch off in the future. If you read the guide on Setting up a production server (see the github read me) it walks through the way we've set Loomio up on Heroku.

DU

[deactivated account] Thu 11 Apr 2013

@jonlemmon thanks, will do

RG

Rafael Gomes Mon 15 Apr 2013

I am try to install loomio on local machine, but I got that error

$ bundle exec rake db:schema:load

rake aborted!
uninitialized constant DiscussionsHelper::Twitter
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin/namespace.rb:191:in eval'
/home/rafaelgomes/loomio/app/helpers/discussions_helper.rb:1:in
'
/var/lib/gems/1.9.1/gems/actionpack-3.2.13/lib/abstract_controller/helpers.rb:135:in block in modules_for_helpers'
/var/lib/gems/1.9.1/gems/actionpack-3.2.13/lib/abstract_controller/helpers.rb:131:in
map!'
/var/lib/gems/1.9.1/gems/actionpack-3.2.13/lib/abstract_controller/helpers.rb:131:in modules_for_helpers'
/var/lib/gems/1.9.1/gems/actionpack-3.2.13/lib/action_controller/metal/helpers.rb:92:in
modules_for_helpers'
/var/lib/gems/1.9.1/gems/actionpack-3.2.13/lib/abstract_controller/helpers.rb:95:in helper'
/var/lib/gems/1.9.1/gems/actionpack-3.2.13/lib/action_controller/railties/paths.rb:18:in
block (2 levels) in with'
/home/rafaelgomes/loomio/app/controllers/application_controller.rb:1:in <top (required)>'
/var/lib/gems/1.9.1/gems/inherited_resources-1.3.0/app/controllers/inherited_resources/base.rb:11:in
module:InheritedResources'
/var/lib/gems/1.9.1/gems/inherited_resources-1.3.0/app/controllers/inherited_resources/base.rb:1:in <top (required)>'
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin/base_controller/menu.rb:2:in
module:ActiveAdmin'
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin/base_controller/menu.rb:1:in <top (required)>'
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin/base_controller.rb:2:in
'
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin/resource_controller/actions.rb:2:in <module:ActiveAdmin>'
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin/resource_controller/actions.rb:1:in
'
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin/resource_controller.rb:2:in <top (required)>'
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin/dashboards/dashboard_controller.rb:3:in
module:Dashboards'
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin/dashboards/dashboard_controller.rb:2:in <module:ActiveAdmin>'
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin/dashboards/dashboard_controller.rb:1:in
'
(eval):1:in generate_dashboard_controller'
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin/namespace.rb:191:in
eval'
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin/namespace.rb:191:in generate_dashboard_controller'
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin/namespace.rb:43:in
initialize'
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin/application.rb:110:in new'
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin/application.rb:110:in
find_or_create_namespace'
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin/application.rb:98:in register'
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin.rb:74:in
register'
/home/rafaelgomes/loomio/app/admin/woc_options.rb:1:in <top (required)>'
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin/application.rb:161:in
block in load!'
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin/application.rb:161:in each'
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin/application.rb:161:in
load!'
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin/application.rb:187:in routes'
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin.rb:78:in
routes'
/home/rafaelgomes/loomio/config/routes.rb:2:in block in <top (required)>'
/var/lib/gems/1.9.1/gems/actionpack-3.2.13/lib/action_dispatch/routing/route_set.rb:289:in
instance_exec'
/var/lib/gems/1.9.1/gems/actionpack-3.2.13/lib/action_dispatch/routing/route_set.rb:289:in eval_block'
/var/lib/gems/1.9.1/gems/actionpack-3.2.13/lib/action_dispatch/routing/route_set.rb:267:in
draw'
/home/rafaelgomes/loomio/config/routes.rb:1:in <top (required)>'
/var/lib/gems/1.9.1/gems/railties-3.2.13/lib/rails/application/routes_reloader.rb:40:in
block in load_paths'
/var/lib/gems/1.9.1/gems/railties-3.2.13/lib/rails/application/routes_reloader.rb:40:in each'
/var/lib/gems/1.9.1/gems/railties-3.2.13/lib/rails/application/routes_reloader.rb:40:in
load_paths'
/var/lib/gems/1.9.1/gems/railties-3.2.13/lib/rails/application/routes_reloader.rb:16:in reload!'
/var/lib/gems/1.9.1/gems/railties-3.2.13/lib/rails/application.rb:108:in
reload_routes!'
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin/reloader.rb:34:in reload!'
/var/lib/gems/1.9.1/gems/activeadmin-0.4.3/lib/active_admin/reloader.rb:61:in
block in attach!'
/var/lib/gems/1.9.1/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:429:in _run__2724464507161681211__prepare__4584786222408841597__callbacks'
/var/lib/gems/1.9.1/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:405:in
__run_callback'
/var/lib/gems/1.9.1/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:385:in _run_prepare_callbacks'
/var/lib/gems/1.9.1/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:81:in
run_callbacks'
/var/lib/gems/1.9.1/gems/actionpack-3.2.13/lib/action_dispatch/middleware/reloader.rb:74:in prepare!'
/var/lib/gems/1.9.1/gems/actionpack-3.2.13/lib/action_dispatch/middleware/reloader.rb:48:in
prepare!'
/var/lib/gems/1.9.1/gems/railties-3.2.13/lib/rails/application/finisher.rb:47:in block in <module:Finisher>'
/var/lib/gems/1.9.1/gems/railties-3.2.13/lib/rails/initializable.rb:30:in
instance_exec'
/var/lib/gems/1.9.1/gems/railties-3.2.13/lib/rails/initializable.rb:30:in run'
/var/lib/gems/1.9.1/gems/railties-3.2.13/lib/rails/initializable.rb:55:in
block in run_initializers'
/var/lib/gems/1.9.1/gems/railties-3.2.13/lib/rails/initializable.rb:54:in each'
/var/lib/gems/1.9.1/gems/railties-3.2.13/lib/rails/initializable.rb:54:in
run_initializers'
/var/lib/gems/1.9.1/gems/railties-3.2.13/lib/rails/application.rb:136:in initialize!'
/var/lib/gems/1.9.1/gems/railties-3.2.13/lib/rails/railtie/configurable.rb:30:in
method_missing'
/home/rafaelgomes/loomio/config/environment.rb:5:in <top (required)>'
/var/lib/gems/1.9.1/gems/railties-3.2.13/lib/rails/application.rb:103:in
require_environment!'
/var/lib/gems/1.9.1/gems/railties-3.2.13/lib/rails/application.rb:297:in block (2 levels) in initialize_tasks'
/var/lib/gems/1.9.1/gems/rake-10.0.4/lib/rake/task.rb:246:in
call'
/var/lib/gems/1.9.1/gems/rake-10.0.4/lib/rake/task.rb:246:in block in execute'
/var/lib/gems/1.9.1/gems/rake-10.0.4/lib/rake/task.rb:241:in
each'
/var/lib/gems/1.9.1/gems/rake-10.0.4/lib/rake/task.rb:241:in execute'
/var/lib/gems/1.9.1/gems/rake-10.0.4/lib/rake/task.rb:184:in
block in invoke_with_call_chain'
/var/lib/gems/1.9.1/gems/rake-10.0.4/lib/rake/task.rb:177:in invoke_with_call_chain'
/var/lib/gems/1.9.1/gems/rake-10.0.4/lib/rake/task.rb:205:in
block in invoke_prerequisites'
/var/lib/gems/1.9.1/gems/rake-10.0.4/lib/rake/task.rb:203:in each'
/var/lib/gems/1.9.1/gems/rake-10.0.4/lib/rake/task.rb:203:in
invoke_prerequisites'
/var/lib/gems/1.9.1/gems/rake-10.0.4/lib/rake/task.rb:183:in block in invoke_with_call_chain'
/var/lib/gems/1.9.1/gems/rake-10.0.4/lib/rake/task.rb:177:in
invoke_with_call_chain'
/var/lib/gems/1.9.1/gems/rake-10.0.4/lib/rake/task.rb:170:in invoke'
/var/lib/gems/1.9.1/gems/rake-10.0.4/lib/rake/application.rb:143:in
invoke_task'
/var/lib/gems/1.9.1/gems/rake-10.0.4/lib/rake/application.rb:101:in block (2 levels) in top_level'
/var/lib/gems/1.9.1/gems/rake-10.0.4/lib/rake/application.rb:101:in
each'
/var/lib/gems/1.9.1/gems/rake-10.0.4/lib/rake/application.rb:101:in block in top_level'
/var/lib/gems/1.9.1/gems/rake-10.0.4/lib/rake/application.rb:110:in
run_with_threads'
/var/lib/gems/1.9.1/gems/rake-10.0.4/lib/rake/application.rb:95:in top_level'
/var/lib/gems/1.9.1/gems/rake-10.0.4/lib/rake/application.rb:73:in
block in run'
/var/lib/gems/1.9.1/gems/rake-10.0.4/lib/rake/application.rb:160:in standard_exception_handling'
/var/lib/gems/1.9.1/gems/rake-10.0.4/lib/rake/application.rb:70:in
run'
Tasks: TOP => db:schema:load => environment
(See full trace by running task with --trace)

How can I solve this?

JL

Jon Lemmon Mon 15 Apr 2013

@rafaelgomes have you installed any Rails apps in the past on your computer? You'll need to make sure that you have all the dependencies installed. What OS are you on? Did you follow the guide?

RG

Rafael Gomes Mon 15 Apr 2013

I am trying to install in Debian 6. I didn't follow this guide because I am not a devel guy, I just put a loomio to test here in Brazil.

RG

Rafael Gomes Mon 15 Apr 2013

@jonlemmon Is there any guide to a non-devel guy?

JL

Jon Lemmon Mon 15 Apr 2013

@rafaelgomes unforunately not at the moment. We definitely plan to make it easier to install Loomio in the future, but right now we have other more urgent priorities.

So realistically, you'll need to have a basic understanding of Rails before you'll be able to install Loomio. The best place to get started learning about Rails is probably here:

http://ruby.railstutorial.org/ruby-on-rails-tutorial-book

RG

Rafael Gomes Mon 15 Apr 2013

hi @jonlemmon I asked to a friend help me with this.

My test server is working, but I got this error when tried login.

couldn't find file 'jqplot.1.0.0b2_r792'
(in /home/rafaelgomes/loomio/app/assets/stylesheets/application.css:6)

My test server : 194.14.56.232:3000

RG

Rafael Gomes Mon 15 Apr 2013

I found this : http://search.4shared.com/postDownload/4B5Wey22/jqueryjqplot100b2_r792.html

But I don't know how install this :(

MI

mix irving Mon 15 Apr 2013

if you look in the Gemfile, you can see:
gem 'jqplot-rails', '~> 0.1'

if you have run:

$ bundle install

this should have installed jqplot ... though i'm not sure how this would make sure we're using jqplot.1.0.0b2_r792

maybe the /application.css file needs changing
thoughts @jonlemmon ?

for reference, the official downloads are at :
https://bitbucket.org/cleonello/jqplot/downloads
the official page is : http://www.jqplot.com/

@rafaelgomes , I highly recommend the Rails Tutorial Jon recommended. It's not too complicated and everything is explained very clearly.

MI

mix irving Mon 15 Apr 2013

sorry, that should read:
gem 'jqplot-rails', '~> 0.1'

RG

Rafael Gomes Tue 16 Apr 2013

@johnirving I promise that I will learn rails, but these days I am very busy to start another thing :(

I did install manually jqplot-rails again, and don't works.

I did reported a bug : https://github.com/loomio/loomio/issues/656

I don't know if it is a bug or not. Sorry if I am doing it wrong.

JL

Jon Lemmon Tue 16 Apr 2013

Hey @rafaelgomes, unfortunately we don't have the time/resources to help you get Loomio installed right now if you don't have basic Rails knowledge. However, once you've gone through the tutorial we've recommended and have a basic level of knowledge with Rails apps then we'll be happy to help you sort out any issues.

But for starters, I would recommend installing on Ubuntu. We don't really have any developers running Debian so it will be harder for us to support you if you're running on Debian.

RG

Rafael Gomes Tue 16 Apr 2013

@jonlemmon ok, I will do that.

About jqplot.1.0.0b2_r792 in css file, it is correct version of this package or it is a error?

Sorry for bother you with these things. I hope help you in the future.

JL

Jon Lemmon Tue 16 Apr 2013

@rafaelgomes No worries. =)

To be honest, I don't really know much about jqplot because I didn't install it in Loomio. I've never heard of anyone having to download it separately though, it should just work in Loomio straight-out-of-the-box.

RG

Rafael Gomes Tue 16 Apr 2013

@jonlemmon may be the ubuntu already has this in its default installation.

I will find how install this in Debian. May be to help another guy, like me, to install in Debian too :)

JL

Jon Lemmon Tue 16 Apr 2013

@rafaelgomes hmm, okay. I feel like the only file needed is already included in the github repo already though:

https://github.com/loomio/loomio/blob/master/app/assets/javascripts/lib/jqplot.pieRenderer.min.js

So I'm not really sure why you're getting that error. Hope your bug-hunting goes well! =)

RG

Rafael Gomes Tue 16 Apr 2013

@jonlemmon I already had this file :(

rafaelgomes@suecia2:~$ file loomio/app/assets/javascripts/lib/jqplot.pieRenderer.min.js
loomio/app/assets/javascripts/lib/jqplot.pieRenderer.min.js: ASCII English text, with very long lines

RG

Rafael Gomes Sun 21 Apr 2013

It is weird. I found the file, but the service don't :(

/var/lib/gems/1.9.1/gems/jqplot-rails-0.1/vendor/assets/javascripts/jqplot.1.0.0b2_r792.js
/var/lib/gems/1.9.1/gems/jqplot-rails-0.1/vendor/assets/stylesheets/jqplot.1.0.0b2_r792.css

According this, the package is installed, but may be stay in wrong place.

RG

Rafael Gomes Sun 21 Apr 2013

Thanks for all return, I solved my problem:

wget https://bitbucket.org/cleonello/jqplot/downloads/jquery.jqplot.1.0.0b2_r792.tar.bz2

tar xvjf jquery.jqplot.1.0.0b2_r792.tar.bz2

cp ./dist/jquery.jqplot.js /home/rafaelgomes/loomio/app/assets/javascripts/jqplot.1.0.0b2_r792.js

cp ./dist/jquery.jqplot.css /home/rafaelgomes/loomio/app/assets/stylesheets/jqplot.1.0.0b2_r792.css

sudo foreman start

\o/

RG

Rafael Gomes Sun 21 Apr 2013

After install without any error, I try to click in "Groups" link, and don't show me the menu. The same thing happens in my full name :(

Another thing, I don't have Notification link in my menu, is there any other version of this software?

MI

mix irving Sun 21 Apr 2013

did you set up your first group as described in the 'installing on a local machine' guide?

I can't think of anything that would lead to you not being able to the notifications link. perhaps include a screenshot.

RDB

Richard D. Bartlett Sun 21 Apr 2013

You don't have any notifications yet, so the notifications link doesn't show up. It is a bit weird but that's how it works.

RG

Rafael Gomes Sun 21 Apr 2013

Thanks @richarddbartlett for explanation about "Notifications", but why I can't edit my account configuration and see my Groups? it appear in Menu, but when I click I can't see my groups. :(

Take a look :
http://postimg.org/image/vgt7fygwv/

RDB

Richard D. Bartlett Sun 21 Apr 2013

@rafaelgomes have you followed these steps to create a group?

RG

Rafael Gomes Mon 22 Apr 2013

@richarddbartlett yes. Take a look:

http://postimg.org/image/r9uocllxt/

My first group.

RG

Rafael Gomes Mon 22 Apr 2013

RDB

Richard D. Bartlett Mon 22 Apr 2013

Can you start discussions & decisions in the group?

RG

Rafael Gomes Mon 22 Apr 2013

@richarddbartlett no problem with that :

http://postimg.org/image/5crdp5zyf/

QG

Quentin Grimaud Tue 5 Aug 2014

I just succeeded installing loomio on my Ubuntu 14.04 (after having tried several times without success on my 12.04 => could not manage to install the required versions of ruby and rails). So here is a text file where I wrote each problem I had during installation, and how I fixed them. Hope this helps for improving the README file!

AI

Alanna Irving Tue 5 Aug 2014

Wow that's great @quentingrimaud ! @robertguthrie @hannahsalmon check this out.

RG

Rob Guthrie Tue 5 Aug 2014

Thanks @quentingrimaud! Awesome.

Note for whoever might iterate on this next: Would be cool to turn this into a list of 1 line error messages you can easily skim through to find a suggested course of action.

DU

[deactivated account] Wed 6 Aug 2014

Thanks heaps @quentingrimaud! We'll definitely integrate that into our existing documentation!

FA

FABRICE ALCINDOR Thu 8 Feb 2018

Hi, I try to install Loomio on Ubuntu 14.04 and I'l in trouble. I follow this tutorial: https://github.com/loomio/loomio/blob/master/docs/en/development_handbook/setup_environment.md

Install Node.js
You'll need Node.js and it's best if you use nvm to install it. From https://github.com/creationix/nvm You'll find that you need to run:

curl -o- https://raw.githubusercontent.com/creationix/nvm/v0.33.6/install.sh | bash
Now build and install node

I'm stuck at this instruction.

$ nvm install 8.4.0
$ nvm alias default 8.4.0
$ bundle install
$ npm install -g yarn gulp
$ cd client
$ yarn

Where can I find the "client" directory?
Thanks in advance

JK

James Kiesel Thu 8 Feb 2018

@faf The /client directory is in the folder where you cloned loomio.

git clone https://github.com/loomio/loomio.git
cd loomio/client

FA

FABRICE ALCINDOR Fri 9 Feb 2018

thx @gdpelican . That was my first guess, but it is not. Is it generated or shall it be there as soon as repo si cloned?
Here the commit checkout sha: ad825a07065a5bfaa1919edfe2b883058b4fd8a8

JK

James Kiesel Fri 9 Feb 2018

That is a pretty old commit (Dec 29), and we've since moved the 'angular' folder into 'client'. Can you update to the latest repo?

FA

FABRICE ALCINDOR Fri 9 Feb 2018

Seems much better. Thanks @gdpelican

FA

FABRICE ALCINDOR Mon 12 Feb 2018

Hi,
I have finished the install procédure of the dev loomio on my VM Ubuntu 14.04. I start the server with the following command:

rails s
Server starts:
/home/alibivmuser/.rbenv/versions/2.4.3/lib/ruby/gems/2.4.0/gems/railties-5.1.4/lib/rails/app_loader.rb:40: warning: Insecure world writable dir /opt/alibi in PATH, mode 040777
=> Booting Puma
=> Rails 5.1.4 application starting in development
=> Run rails server -h for more startup options
Warning: method update already defined
[29097] Puma starting in cluster mode...
[29097] * Version 3.11.0 (ruby 2.4.3-p205), codename: Love Song
[29097] * Min threads: 2, max threads: 8
[29097] * Environment: development
[29097] * Process workers: 2
[29097] * Preloading application
[29097] * Listening on tcp://0.0.0.0:3000
[29097] Use Ctrl-C to stop
[29097] - Worker 0 (pid: 29132) booted, phase: 0
[29097] - Worker 1 (pid: 29143) booted, phase: 0

I was first surprised by the listening adress prompted (see above 0.0.0.0) . I was expecting something like "localhost" of 127.0.0.1.

I found in an other thread that we shall then connect to http://127.0.0.1:3000
I did so but then I have the following

On server console

Started GET "/" for 127.0.0.1 at 2018-02-11 22:04:52 +0100
Processing by RootController#index as HTML
Redirected to http://localhost:3000/dashboard
Completed 302 Found in 227ms

Started GET "/dashboard" for 127.0.0.1 at 2018-02-11 22:04:52 +0100
Processing by ApplicationController#index as HTML
Rendering application/index.html.haml
Rendered angular/_metadata.html.haml (7.6ms)
Rendered application/_google_analytics.html.haml (1.6ms)
Rendered application/index.html.haml (513.5ms)
Completed 200 OK in 598ms (Views: 515.8ms | ActiveRecord: 8.4ms)

On my firefox console:

WARNING: content window passed to PrivateBrowsingUtils.isWindowPrivate. Use isContentWindowPrivate instead (but only for frame scripts).
pbu_isWindowPrivate@resource://gre/modules/PrivateBrowsingUtils.jsm:25:14
pbs<@resource://unity/observer.js:38:71
Observer.prototype.observe@resource://unity/observer.js:77:24
blank

I first think it was due to my browser but it is the same with Google Chrome.

I'm a bit confuse while I can't point to any error to investigate what I might missed?
Any idea?
Thanks in advance,

Fabrice