Loomio

Dumb question: self-hosting Loomio 2

JN
Jade Northrup Public Seen by 39

Hi, I read somewhere (a while back) that self-hosted Loomio instances can only use the Loomio 1.x interface. Is that no longer true?

If it’s possible to upgrade an old Loomio 1.x install, is there a data migration process? Thanks for any info, and sorry if this is covered elsewhere.

RG

Rob Guthrie Mon 4 May 2020

Hi @Jade Northrup. Not a dumb question! However, I don't know what you are referring to in your first sentence, it's never been true.

It is possible to upgrade an old instance to the latest version of Loomio.

docker-compose pull
docker-compose down
docker-compose run app rake db:migrate
docker-compose up -d

These are the instructions from the loomio-deploy repo.

It can be a little rocky to upgrade sometimes, if your system is very old, as sometimes migrations refer to classes that no longer exist, so it's good to keep current.

But if you do get stuck, and you have some patience to go back and forward with me for a day or 3 then I'm sure you can upgrade. I'll fix any broken migrations if you report them to me here in this thread.

Good luck!