Loomio

Problems in Threads, Poll and "Members" in portuguese.

FDS
Fabio dos Santos Public Seen by 51

Hi @Rob Guthrie .

We have been testing the setup to make sure it meets our needs. And have come across 3 issues. 2 of them are important, and a third minor one.

I have already tried the "lastest" loomio (updating it in .env and running a docker-compose pull, as per Loomio-Deploy). I'll attach each error as separate coments, below.

FDS

Fabio dos Santos Tue 28 Apr 2020

1st: Is related to comments. We've been making comments and they are starting to not show up on the page, even after refreshing the page.


FDS

Fabio dos Santos Tue 28 Apr 2020

About this error, I also get this quick notification when I reload the page:

RG

Rob Guthrie Wed 29 Apr 2020

If you have changed from "stable" to "latest" then make sure you have run the migrations (instructions are in the readme).

If comments are not showing up I expect there are errors in you docker-compose logs that might help explain what's going on

FDS

Fabio dos Santos Wed 29 Apr 2020

I ran de instructions on the loomio-deply. How do I check if I have the latest?

Here is the pastebin with the messages: https://pastebin.pl/view/d5ea7a6e

RG

Rob Guthrie Wed 29 Apr 2020

Gosh. I can't see anything that might be the reason your comments aren't loading from that pastebin.

Are there errors in your javascript console in your browser?

RG

Rob Guthrie Wed 29 Apr 2020

please try disabling any adblockers or script blockers. Just to see if it makes any difference.

FDS

Fabio dos Santos Wed 29 Apr 2020

Sorry. How do I check Javascript?

FDS

Fabio dos Santos Sat 2 May 2020

I have not been able to reproduce de error again. It might have been a particular circumstance

(I think it might have been something like unpinning a proposal or a poll?) I'm not completely sure.

I'll keep trying, and see what happens.

FDS

Fabio dos Santos Tue 28 Apr 2020

2nd one is about the Poll. We only had 3 people on the thread, and yet Loomio was counting 3 people. Would this be an error, or maybe we configured it wrong?

RG

Rob Guthrie Wed 29 Apr 2020

If you run this on "latest", then you should have a link to the poll page from the title of the poll, it will show who the 3 people are.

FDS

Fabio dos Santos Tue 28 Apr 2020

3rd one is probably and easy fix. In the portuguese interface, "Members" show up like this:

RG

Rob Guthrie Wed 29 Apr 2020

Yikes, looks like we have a problem with the portuguese translations. If you have time you can improve them by joining our Transifex community. I think you can search for specific strings and provide updated translations.

I'll then pull the updated strings into the latest release.

FDS

Fabio dos Santos Wed 29 Apr 2020

Done in Transifex! How do I pull the updated strings? Just a "docker-compose pull" ?

RG

Rob Guthrie Wed 29 Apr 2020

Thank you very much!

I've just pulled from transifex. docker-compose pull in about an hour from now (at least).

FDS

Fabio dos Santos Wed 29 Apr 2020

THANKS!

I noticed that the client is not yet fully translated. I'll keep working on it. :-)

FDS

Fabio dos Santos Sat 2 May 2020

Just to let you know. I just finished translating the Loomio Client to Portuguese (Brasil) on Transifex. Can you pull it to latest, please?

RG

Rob Guthrie Sun 3 May 2020

done. Thank you so much! It should be updated in an hour from now.