Loomio

Loomio unable to send out email

J
Jason Public Seen by 151

I've recently inherited management of a self hosted loomio site. The issue I'm having is the site is unable to send out sign up/sign in emails after we transitioned to G suite for our email service.

I've looked over all the possibly related posted here and gotten pretty comfortable with how loomio is set up but still no luck.

  • Backed up the database.

  • Tried changing my SMTP service details from Gmail to an Amazon SES.

  • Updated to the latest version of loomio

  • Played around with my SMTP setting both Gmail and AWS to see if I was configuring something wrong.

I'm not super sure what I'm looking at in the logs but based on the other posts here I still think it's an SMTP configuration issue. There is mention of a failed connection to Redis in the log file.

env file:

https://pastebin.com/UYFz8qr6

Log file:

https://pastebin.com/MXtbvfpu

Any help to point me in the right direction would be great, thanks!

J

Jason Sun 15 Mar 2020

After a lot of digging it was my docker-compose.yml and .env file missing a few lines of important information.

FDS

Fabio dos Santos Wed 15 Apr 2020

Hi @Jason Could ou share what you did to solve this, please?

J

Jason Wed 15 Apr 2020

Hi @Fabio dos Santos from memory it was my Redis server setup. Make sure all the necessary containers are set up and are communicating correctly. Check the error logs to see whats coming up.

RG

Rob Guthrie Mon 16 Mar 2020

Pleased you worked it out!